Программа "mpConfig" не работает - ModPlus

Программа "mpConfig" не работает

4 года 2 мес. назад
iMrVoLaNd
Осваиваюсь на форуме
Осваиваюсь на форуме
Сообщений: 36
Больше
Автор темы
Программа "mpConfig" не работает #269
Запустил сегодня конфигуратор, пошла загрузка списка функций, увидел, что вышло обновление на функцию "Примечания", а после этого Программа "mpConfig" не работает.

Вложения:

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

4 года 2 мес. назад
iMrVoLaNd
Осваиваюсь на форуме
Осваиваюсь на форуме
Сообщений: 36
Больше
Автор темы
Программа "mpConfig" не работает #270
1. Пришлось удалять mpConfig.mpcf и заново его перенастраивать :( Думаю проблема может быть связана с тем, что внешний винт, к которому привязан ключ не был подключен.
2. При запуске Конфигуратора в фильтре активна кнопка "Включить все" (при этом в фильтре выбрано отобразить все функции для всех autocad). Она не работает к сожалению при такой настройке фильтра. В дальнейшем, если переключить фильтр на конкретные версии Autocad и вернуть снова на "Все" - кнопка уже не появляется. Если возможно - сделайте возможность включать функции сразу для всех активных версий autocad.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

4 года 2 мес. назад 4 года 2 мес. назад от Modis.
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #271

iMrVoLaNd пишет: 1. Пришлось удалять mpConfig.mpcf и заново его перенастраивать :( Думаю проблема может быть связана с тем, что внешний винт, к которому привязан ключ не был подключен.

Мне кажется, что Вы попали в точку! Скорее всего из-за винта. Я этот вариант сделал, но должного тестирования провести не могу. Вот и попадаются такие недочеты и глюки

iMrVoLaNd пишет: 2. При запуске Конфигуратора в фильтре активна кнопка "Включить все" (при этом в фильтре выбрано отобразить все функции для всех autocad). Она не работает к сожалению при такой настройке фильтра. В дальнейшем, если переключить фильтр на конкретные версии Autocad и вернуть снова на "Все" - кнопка уже не появляется. Если возможно - сделайте возможность включать функции сразу для всех активных версий autocad

Вот как-раз активность кнопки "включить все" при том, что в фильтре стоит "отобразить все" - это и есть недочет, а не наоборот))) Кнопка работает только для конкретной версии автокада

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

4 года 1 мес. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #274
Провел тесты - отсутствие винта оказывается не причем. И это плохо - теперь я не могу узнать причину возникновения ошибки и, следовательно, исправить ее

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

4 года 1 мес. назад
iMrVoLaNd
Осваиваюсь на форуме
Осваиваюсь на форуме
Сообщений: 36
Больше
Автор темы
Программа "mpConfig" не работает #277
Я тоже дома провел тесты и первый запуск с подключенным внешним винтом произошел тоже с ошибкой. Удалил конфиг - конфигуратор запустился. Сейчас его настрою и попробую сравнить два конфига, может там какие-то определенные параметры крашат его.
1. Словил еще один краш при попытке сменить тему конфигуратора. (но после запуска тема стала все таки темная). Тема плагина до этого поменялась без проблем.
2. Фильтр отображения функций работает некорректно. Если убрать все галочки отображает 30 функций (все подключены). Если ставлю галочку в фильтре "Подключенные" - отображает только 19 подключенных функций.
3. Что должен отображать фильтр "Новые"? Последние добавленные функции? Последние добавленные и не подключенные функции?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
dimapavl
Новый участник
Новый участник
Сообщений: 14
Больше
Программа "mpConfig" не работает #375
Программа зависает при запуске на рабочем компьютере (см. скриншот). При том на домашнем компьютере работает нормально. Привязана к флэшке. Из-за чего он так грузит систему?
Вложения:

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #376
Может что-то связанное с сетью. Дома обычно вся сеть доступна, а на работе могут быть ограничения. Попробуйте отключить интернет и запустить конфигуратор. И обязательно отпишите о результатах.
Конфигуратор еще далеко не идеален и в нем еще многое нужно переделывать. А всех проблем чисто физически я не могу сам "отловить"

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
dimapavl
Новый участник
Новый участник
Сообщений: 14
Больше
Программа "mpConfig" не работает #379
Проверил, то же самое.
Александр, дело в том что 4 дня назад на работе все работало нормально. Проблемы сначала были с обновлением программы, а потом программа вовсе перестала запускаться. А с обновлением было следующее: Когда нажимал обновить, программа вылетала с ошибкой. Я вроде обошел ее, обновлял дома и пользовался нормально на работе.
И еще приходится постоянно настраивать значки через "Построить стандартно". И еще не получается сохранить файл конфигурации, постоянно вылетает с ошибкой

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #381
Вы прям меня пугаете. Вроде я особо ничего не менял в конфигураторе - не могу даже понять что происходит ((
Сначала попробуйте что я написал в соседней теме:
Скачайте конфигуратор в виде архива - modplus.org/mnu-configurator
Откройте архив и скопируйте из него конфигуратор в папку ModPlus с заменой. Попробуйте запустить конфигуратор - если все будет хорошо, то должен появиться и запуститься модуль автоматического обновления.
Если не сработает - попробуйте сначала удалить файл конфигурации

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
dimapavl
Новый участник
Новый участник
Сообщений: 14
Больше
Программа "mpConfig" не работает #382

Modis пишет: Вы прям меня пугаете. Вроде я особо ничего не менял в конфигураторе - не могу даже понять что происходит ((
Сначала попробуйте что я написал в соседней теме:
Скачайте конфигуратор в виде архива - modplus.org/mnu-configurator
Откройте архив и скопируйте из него конфигуратор в папку ModPlus с заменой. Попробуйте запустить конфигуратор - если все будет хорошо, то должен появиться и запуститься модуль автоматического обновления.
Если не сработает - попробуйте сначала удалить файл конфигурации

Ничего не получилось. Все так же. На работе вообще не запускается. А так нужен по работе. Что делать?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #383

dimapavl пишет: Ничего не получилось. Все так же. На работе вообще не запускается. А так нужен по работе. Что делать?

1. Одной из причин по которой вообще не запускается - это наличие антивируса. Если у вас стоит Аваст, то из-за него может не открываться конфигуратор и при этом не будет никаких сообщений. Сам такое видел. Аваст (как и другие антивирусы) можно отключать на время
2. Попробуйте полностью удалить плагин (и папку и файл конфигурации), скачать архив с сайта и установить все заново. И лучше, наверно, завтра, т.к. сегодня обнаружилась небольшая проблема в модуле автообновления и сегодня буду исправлять и обновлять

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
dimapavl
Новый участник
Новый участник
Сообщений: 14
Больше
Программа "mpConfig" не работает #384

Modis пишет:

dimapavl пишет: Ничего не получилось. Все так же. На работе вообще не запускается. А так нужен по работе. Что делать?

1. Одной из причин по которой вообще не запускается - это наличие антивируса. Если у вас стоит Аваст, то из-за него может не открываться конфигуратор и при этом не будет никаких сообщений. Сам такое видел. Аваст (как и другие антивирусы) можно отключать на время
2. Попробуйте полностью удалить плагин (и папку и файл конфигурации), скачать архив с сайта и установить все заново. И лучше, наверно, завтра, т.к. сегодня обнаружилась небольшая проблема в модуле автообновления и сегодня буду исправлять и обновлять

Да, действительно, у меня антивирус Аваст. Отключил и все заработало.
Тогда у меня следующие вопросы:
1. До начала проблем у меня аваст был, и все работало нормально. Почему перестал работать?
2. Дома у меня с активным Авастом все работает. Проблем нет. А на работе же не идет.
И еще вопросы по файлу "mpConfig.mpcf":
1. где этот файл должен храниться? на флешке с программой или на компьютере?
2. он может быть общим что для домашнего и для рабочего компьютера и храниться на флешке в папке с программой (как у меня сейчас)?
Мне каждый раз приходится перенастраивать меню на стандартное, когда меняю компьютеры. Что не совсем удобно

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #385

1. До начала проблем у меня аваст был, и все работало нормально. Почему перестал работать?
2. Дома у меня с активным Авастом все работает. Проблем нет. А на работе же не идет.

Могу предположить, что антивирус тоже обновляется. У меня на работе на двух компах, которые стоят в метре друг от друга, стоит Аваст. Вроде как одинаковый совершенно - но вид основного окна антивируса отличается в корне!
Видимо это зависит не только от самого Аваста, но и еще от каких-то причин. Потому-что у меня дома Аваст, на работе у всех Аваст - и везде антивирус реагирует на плагин по-разному: может не реагировать, может пропустить через "песочницу", а может вообще не открыть

И еще вопросы по файлу "mpConfig.mpcf":
1. где этот файл должен храниться? на флешке с программой или на компьютере?
2. он может быть общим что для домашнего и для рабочего компьютера и храниться на флешке в папке с программой (как у меня сейчас)?
Мне каждый раз приходится перенастраивать меню на стандартное, когда меняю компьютеры. Что не совсем удобно

Изначально плагин продумывался для работе на одном компе. Соответственно и мобильность файла настроек не предусматривалась. Вариант привязки к флешке вообще появился позже. Поэтому файл должен хранится на компьютере "от греха подальше"
Конечно можно его использовать один для двух компов, но с трудностями в части постоянной перенастройки некоторых настроек.
Плагин не стоит на месте и я буду в будущем рассматривать варианты мобильности, хранения данных на онлайн дисках и пр. Просто - не все сразу) Я везде не успеваю

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
dimapavl
Новый участник
Новый участник
Сообщений: 14
Больше
Программа "mpConfig" не работает #386
Александр, проблемы решены:
1. Действительно у меня 2 разных Аваста дома и на работе. На рабочем компе решил проблему добавив папку с ModPlus в исключения в антивирусе.
2. По файлам "mpConfig.mpcf" тоже решил, установив их локально на каждом компьютере. Теперь работает все нормально.
Спасибо большое!!! Буду использовать программу дальше в нормальном режиме

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
nickosh
Новый участник
Новый участник
Сообщений: 3
Больше
Программа "mpConfig" не работает #388
юзал модплюс на ПК - понравилось
запустил конфигуратор на ноутбуке (W7 64) под учеткой администратора
проблема:
при запуске автокад 2013 под учеткой админа все работает нормально, но при запуске автокад под учеткой пользователя автокад не видит плагин
пробовал запустить конфигуратор под учеткой пользователя, все запустилось, но (как я понял) винда не пускает к папке автокада, в итоге с правами пользователя не появляется вкладка модплюс

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

3 года 9 мес. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #389

nickosh пишет: при запуске автокад 2013 под учеткой админа все работает нормально, но при запуске автокад под учеткой пользователя автокад не видит плагин
пробовал запустить конфигуратор под учеткой пользователя, все запустилось, но (как я понял) винда не пускает к папке автокада, в итоге с правами пользователя не появляется вкладка модплюс

Это один и тот-же комп? Просто конфигуратор создает запись в реестре (для текущего пользователя) и исправляет файл acad.exe.config . Возможно у учетки пользователя не хватает прав на эти действия

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

8 мес. 1 нед. назад
Fitolaks
Новый участник
Новый участник
Сообщений: 3
Больше
Программа "mpConfig" не работает #1093
После установки последнего обновления, перестал работать конфигуратор. При попытке входа в него, отображается сообщение . Что необходимо сделать для восстановления доступа к конфигуратору?
Вложения:

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

8 мес. 1 нед. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #1094
Попробуйте обновиться, используя веб-установщик, и потом еще раз запустите конфигуратор

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

8 мес. 1 нед. назад
Fitolaks
Новый участник
Новый участник
Сообщений: 3
Больше
Программа "mpConfig" не работает #1097
Первая попытка обновления, которая привела к поломке конфигуратора, как раз и была выполнена через веб-установщик. После чего я попробовал обновиться вручную через скачивание и запуск из меню Модплюса файла AutoUpdater_3.0.8.0.mpif. Результат все равно такой же - конфигуратор не работает. Что еще можно сделать?

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

8 мес. 1 нед. назад
Modis
Администратор
Администратор
Сообщений: 612
Репутация: 10
Больше
Программа "mpConfig" не работает #1098
Сделайте скриншот реестра

Вложения:

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.